OnUtilityHook error

Users are reporting they are unable to log in. When I tried I’m getting an “onUtilityHook Error”.

"There was an issue with the utilityHook: undefined is not an object (evaluating ‘delete e.state.modelUpdatemode’)

Any thoughts?

Start with a few things:

This was resolved with a reboot of the server.

This has cropped up again yesterday. We’ve rebooted the FileMaker Server, the XML gateway test is failing. Suggestions on what to try next?

How stable is the server in general, anything else running on it?
I know for unstable servers where various issues like CPU and drive space come up, the XML gateway can fail.

If its stable, the gateway runs pretty stable too. We seldom have an issue.

I have a small script that will try to restart it once a minute if you cant figure it out.

We’re down to about 20% free space. I’m going to get the IT guys to clear out some of the backups and see what happens. Will post here once I know what’s going on.

Nothing else on the Server other than backup software. Disk has about 165 gb free.

Still haven’t been able to figure it out.

Going to localhost or on the FMS machine returns errors. Still get the UtilityHook error and the gateway test continues to fail. Tried both the XML and DAPI. I’m up to trying the script.

Server is macOS Monterey 12.3.1
FMS is

Are you able to get the fms splash screen when hitting the server domain from a browser?

If not there is either a forwarding or connectivity issue or or deeper fms issue.

And you tried rebooting I’m assuming.

Many reboots. No splash screen. IT guy showed me the routing tables - 5003, 80, & 443 all pointing to the right spot. Web Direct not working either.

Terminal is giving a “command not found” for certain fmsadmin commands. GET cwpconfig, etc.

We’re thinking we might have to wipe and start over.

Re-insatalled everything today; macOS and FMS. Still getting the OnUtilityHook error. Tried going to the login page (fail) and the domain for the FMS (also failed).

When I ping’d .fmbetterforms.com, it gave 100% packet loss. Terminal says it’s going to alias-us-west.bfoperations.com. Guessing that’s the issue. Any suggestions?

I think this was followed up in Slack, but with out FMS working FM BetterForms pages of course can not work. Thus, pinging your domain showing that it is connected to one of the DC’s is correct.

In short, make sure ( in order )

  • Basic FMS is working ( can open files in FM client
  • FMS server splash page works
  • The FMS gateway test page works ( from FM BetterForms servers page )
  • You can see both helper and business files in the XML test page if using XML )
  • The /api endpoint returns data yourapp.fmbetterforms.com/api should return basic JSON and create an inbox record

Opening files - no problem
FMS Server Splash - nope
FMS gateway test page - nope
The /api endpoint returns nothing - view source return an HTML wrapper with = $0
Using XML

The Web Direct splash isn’t working either. Web Direct is enabled. Is there a way to enable the FMS web server via Terminal? Almost as if it isn’t running. WPE is running, Host name is correct. 80 and 443 are pointed to the FM server machine. I can ping the domain being used by FMBF from my local machine.

Update: there was an error in the httpconf file. They IT folks fixed that.

The FMS splash screen is displaying
The gateway test page works
Both files are showing in the gateway test page
The /api endpoint is not displaying anything
The login page is still displaying the OnUtilityHook error
No entry in the Helper inBox